Error Failed to find anything in domain DN when installing HP Anyware Connector

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ERROR Failed to find anything in domain DN

 

Issue:

When trying to install HP Anyware Connector you receive the error "ERROR Failed to find anything in domain DN: dc=172,dc=31,dc=18,dc=194" (note that the ip in the error will not be the same).

The most notable symptom is that there is an IP address where their should be Active Directory DNs: DN: dc=172,dc=31,dc=18,dc=194. If this is not the case, please ensure LDAPs is enabled and your domain controller is reachable from the HP Anyware Connector via IP and hostname

 

Example:

During install of HP Anyware Connector

 

Enter the AD service account password to be used by Cloud Access connector: ****************
[2021-11-30T23:36:19Z] INFO trying to validate service account credential ...
[2021-11-30T23:36:19Z] INFO Cloud Access connector security options mfaEnabled=false userProvidedSSLCert=false
[2021-11-30T23:36:19Z] INFO Cloud Access connector domain controller addresses dcs=[your domain controller name]
[2021-11-30T23:36:19Z] INFO signIntoCAM: Retrieving API key
[2021-11-30T23:36:24Z] INFO signIntoCAM: Received Deployment ID deploymentID=your ID
[2021-11-30T23:36:24Z] INFO signIntoCAM: Signing into CAM Service and retrieving auth token
[2021-11-30T23:36:24Z] INFO registerConnector: Registering new CAS Manager Connector
[2021-11-30T23:36:24Z] INFO getCAMSettings: Retrieving connectorSettings setting from CAM Service
[2021-11-30T23:36:24Z] INFO Connector settings have already been defined for this deployment; the new values provided will take precedence over previously-defined settings
[2021-11-30T23:36:24Z] INFO getCAMSettings: Retrieving logconfig setting from CAM Service
[2021-11-30T23:36:24Z] INFO verifyADSyncBaseDN: Verifying Base DN
[2021-11-30T23:36:24Z] INFO verifyADSyncBaseDN: LDAP search attribute=[dn] dn=dc=172,dc=31,dc=18,dc=194 filter=(objectclass=*)
[2021-11-30T23:36:24Z] ERROR Failed to find anything in domain DN: dc=172,dc=31,dc=18,dc=194
ubuntu@ip-172-31-22-14:~$

 

Cause:

If you receive this error it is likely that during an install attempt, when prompted for your domain, you accidently entered the ip address of your domain controller instead of the domain name. This entry must be your domain name (not domain controller or IP).

 

Solution:

To fix this issue, it will not work to re-run the install command with the proper domain name because this info has been cached in the CASM deployment.


If this is a new deployment with no HP Anyware Connector:

  1. Delete the deployment from the CASM Dashboard
  2. Create a new deployment
  3. Re-run the install command with your new deployment token
  4. Ensure you enter your domain name when prompted instead of domain controller fqdn or IP