PCoIP display is 'blurry' and the image is of lower than expected quality

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Problem

When using PCoIP the display is 'blurry' or of low quality. The display may be persistently blurry or is blurry intermittently and slow. 

 

Cause

Typically a blurry screen is due to the lack of bandwidth. Throughout a PCoIP session, PCoIP network algorithm intelligently monitors network metrics to estimate how much network bandwidth is available. If the network metrics indicate that there is congestion on the network, PCoIP reduces the estimate of how much bandwidth is available. The number of pixels changing on the screen dictates how much data needs to be transferred. If there is a low number of pixels changing, a reduction in estimated bandwidth may not impact the session. If there are more pixels changing than available bandwidth, PCoIP optimizes frame rate and initial image quality to fit in the available bandwidth. When the quality drops low enough this causes the display to be 'blurry'. Typically if the screen is fairly static the image should clear up in the next few delivered frames. The time this takes depends on the current network conditions. See: How to identify network issues in PCoIP Logs

 

Resolution

There are two main scenarios for blurry displays

 

PCoIP display is persistently blurry

 

LAN or high bandwidth network

When the display is persistently blurry on a high speed network there maybe a network issues between two devices or the PCoIP settings have been changed. PCoIP has settings configurable via Group Policy in Windows and a text file in Linux. These settings allow customization of PCoIP settings including the maximum initial image quality. When the maximum initial image quality is set below 70 the initial frame will be noticeably compressed and will build in subsequent frames, assuming the pixels haven't changed such as when watching a video. In a high speed network environment the subsequent frames will come through rapidly so the display will only be blurry momentarily. If this is the case, review the PCoIP settings to ensure the maximum initial image quality has not been turned down.

If the image is persistently blurry and is only slowing building back to a higher quality image on static displays it maybe a network related issue. Review the PCoIP Zero Client AWI, Software Client logs, Remote Workstation Card AWI or PCoIP Server logs on the PCoIP Agent to network issues such as high latency and packet loss. How to identify network issues in PCoIP Logs. If there is network issues ensure there are no devices such as Intrusion Detection Services, Firewalls or bad network connections running at a lower speed or half duplex between the client and host. If there is a security gateway in the configuration, ensure it is not over subscribed. Troubleshooting PCoIP packet loss on the LAN and WAN networks?

 

WAN, low bandwidth or Wireless Network

On a low bandwidth network, follow Network session checklist for PCoIP protocol LAN and WAN deployments in regards to setting QoS and PCoIP session settings. 

 

Remote Workstation Card

One common cause of blurry displays on host card is dithering. When dithering is enabled, every pixel on the screen toggles between two colours many times a second. All of these changes are required to be transmitted and can result in a blurry display. To check if dithering is enabled, open the remote workstation card AWI and look at the Input Change Rate. If the screen is static and the input change rate is pegged at 60 fps then investigate dithering. Graphics card temporal dithering impact on a PCoIP Remote Workstation card

 

PCoIP display is occasionally blurry

 

WAN or low bandwidth

Typically on a WAN, low bandwidth or wireless network there will be packet loss. Where possible follow Network session checklist for PCoIP protocol LAN and WAN deployments and set QoS. Following the recommendations should help minimize the frequency of the blurry displays. 

 

Wireless Network

On a Wireless Network there will be occasions where blurry displays are experienced. Due to the nature of a wireless network packet loss will occur and it cannot be fixed by QoS or any other network configuration. Configuring the PCoIP settings for a low bandwidth network for all PCoIP session running on wireless can help alleviate some congestion. If an intermittent blurry display is unacceptable, the wireless portion of the network must be replaced with a reliable wired network.