Why can't I change the display resolution in Windows when using HP Anyware on Windows?

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Problem

When connected to a remote machine via HP Anyware on Windows, opening the display settings results in greyed out options and a message "Some settings are controlled by your system administrator". You cannot change the screen resolution, select the main display (primary), display placement (topology) or extend/disconnect displays.

 

Cause

HP Anyware disables the ability of the user to change the display settings intentionally. In order to successfully establish a fully functional PCoIP session, it is imperative that display settings are controlled by the PCoIP Agent based on the requests of the PCoIP Client. The display settings are set by the PCoIP Agent dynamically at the start of the setting and during the session. Failure to accurately set the display settings cause issues including:

  • No cursor or incorrect tracking to true position
  • Black or grey displays
  • Incorrect topology
  • 'Resolution not supported' or equivalent on the client's displays
  • Resolutions not accurately matching the client's abilities

 

Resolution

Display resolutions are set based on the capabilities and requested settings of the client, except it is possible to override the primary display resolution when using the PCoIP Standard Agent for Windows. The following instructions are for the clients and PCoIP Standard Agent for Windows.

 

PCoIP Zero Client

Topology and display resolution must be set prior to connection with the HP Anyware Host. The PCoIP Zero Client display topology and screen resolution information is used when establishing the PCoIP session to set the required display settings. To modify the topology and display resolution:

  1. In the OSD, select Options, User Settings.
  2. Select the Display Topology tab.
  3. Tick Enable Configuration
  4. Select the preferred Layout
  5. Change the Primary Display, Position, Rotation and Resolution as required.
    Note: If your preferred display resolution is not listed, this is because the monitor does not advertise the resolution as supported in it's EDID information.

Using a custom display resolution and the Hot Plug Reset function on a PCoIP Zero Client

 

Software Client

The software client uses the display resolution and topology of the Operating System it is running on when in full screen mode. When in windowed mode, the client will adjust the resolution to match the window size when possible.

If the local display resolution has been set to anything but the optimal resolution for the attached display, when running the client in full screen mode black borders will appear around the desktop.
 

 

PCoIP Standard Agent for Windows

The primary display resolution can be set via GPO. The selected resolution will be forced on the primary display. If the display attached to the PCoIP Client is not compatible with the selected resolution it may result in no display. Once set, the setting takes effect at the start of the next PCoIP Session.
 

Note:

When the HP Anyware Agent is uninstalled, the uninstaller should re-enable the capacity to modify the display settings of machine. If after uninstalling the agent & rebooting the PC, the display settings are still locked and restrictions are not clear then you can try following registry setting:

delete NoDispCPL or set it to '0' in the registry under HKLM->Software->Microsoft->Windows->CurrentVersion->Policies->System

This should remove the lock on the display settings lock.