Why can I not establish a PCoIP connection through my Palo Alto firewall?

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Scenario

With the PCoIP Transport Header enabled and using a Palo Alto firewall:

  • PCoIP Zero Clients fail to open a session and show a black screen. The PCoIP Zero Client must be rebooted to get out of this state.
  • Soft clients will only be able to connect on the first session connection while subsequent connections fail. (Multiple soft client sessions from behind a NAT fail)

 

Cause

The Palo Alto firewall does not have the required content update installed.

Resolution

Ensure Palo Alto content update version 341  (November 27th 2012) or newer is installed. 

If the content update is installed. Ensure the correct rules for PCoIP are in place.