Unable to connect (0x1001) when a PCoIP Zero Client tries to connect to a PCoIP Remote Workstation Card

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Problem

When a PCoIP Zero Client is trying to connect to a PCoIP Remote Workstation Card. Clicking the connection button on the PCoIP Zero Client, the error message "Unable to connect (0x1001). Please contact your IT administrator" is returned

 

Cause

The error message indicates the PCoIP Zero Client couldn't establish a connection to the PCoIP Remote Workstation Card.

 

Resolution

In general, be sure the following conditions are met for a PCoIP session:

  • Network cables are firmly connected and the network jack activity lights are on.

  • The PCoIP Remote Workstation Card and PCoIP Zero Client are reachable on the network (e.g., subnets are not masked).

  • The session type is set to Direct to Host in the Session tab of the OSD or Administrative Web Interface.  

  • If you are using a broker, ensure the session type is Auto Detect or PCoIP Connection Manager. 

  • PCoIP Remote Workstation Card is not already in session with another client. Check to see if the green session LED is out.

If the Host Discovery option is enabled in the OSD: 

  • Host Discovery uses the Service Location Protocol (SLP), which requires devices to respond when it discovers them. So, the host PC/workstation should be powered on to have the remote workstation card to be discoverable.

  • Be sure the PCoIP Remote Workstation Card and the PCoIP Zero Client are on the same subnet. If they are on different subnets, the PCoIP Remote Workstation Card may not show up in the list of discovered devices. If so, you may have to disable Host Discovery and enter the PCoIP Remote Workstation card\u2019s IP and MAC address in the OSD to connect a PCoIP session.

  • Make sure the host PC is powered on, or the PCoIP session between the PCoIP Zero Client and the PCoIP Remote Workstation Card is in sleep (indicated by a blinking green Power Button LED on the zero client) after remotely powering down the host PC. If the host PC is remotely powered down and the PCoIP Zero Client is restarted (PCoIP Zero Client's Power Button LED is not blinking green), you can remotely power up the host PC by establishing a session with the PCoIP Remote Workstation Card with the Host Discovery option disabled.

 

See also:

How do I use SLP Host Discovery?