Reverting to Legacy Certificates after changing the PCoIP Management Console 2.x and 3.x certificate causes the web interface to fail to load

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Problem

The certificate of the PCoIP Management Console has been updated but the web interface now fails to load.

 

Cause

After uploading the new certificate to the PCoIP Management Console, if your any reason that certificate is not supported, the web interface service will fail to start and you will be locked out of the PCoIP Management Console web interface. Ensure that the certificate meets all requirements as per the Administrators' Guide before uploading the certificate.

 

Resolution

The instructions below provide steps to revert to the Teradici self signed certificate from the Linux console. Once you have reverted the certificate, check the requirements for the PCoIP Management Console certificate and upload new certificates.

 

Step 1

Log into Linux Console and change to root user - you will have to establish a password for root as follows:

[admin@mymc~] sudo passwd
Changing password for user root.
New password:
Retype new password:
Passwd: all authentication tokens updated successfully.

 

Step 2

Next login as root.

[admin@mymc~] su
Password:
[root@mymc~] cd /opt/teradici/cert/backups   (This is the location of the backup of the certs)

 

Step 3

Change to the following directory cd /opt/teradici/cert/backups

Run the list command to locate the required files ls -l

 

Step 4

Replace the jetty and daemon keystore with keystore.self_signed certificates by running the following commands and responding with y to overwrite the existing files:

  • cp /opt/teradici/cert/backups/keystore.self_signed /opt/daemon/src/main/resources/daemon.keystore
  • cp /opt/teradici/cert/backups/keystore.self_signed /opt/jetty/etc/keystore

 

Step 5

Restart the jetty and mcdaemon services by the following commands. 

Management Console 2.x

service jetty restart
service mcdarmon restart

Management Console 3.x


systemctl restart jetty
systemctl restart mcdaemon

 

Step 6

You should now be able to log into the web interface of the PCoIP Management Console.

You will still need to troubleshoot why your certificates are not working.

 

Pertains to:
  • PCoIP Management Console 2.0.0
  • PCoIP Management Console 2.0.1
  • PCoIP Management Console 2.0.2
  • PCoIP Management Console 2.1.0
  • PCoIP Management Console 2.1.1
  • PCoIP Management Console 2.2.0
  • PCoIP Management Console 2.3.0
  • PCoIP Management Console 2.4.0
  • PCoIP Management Console 2.5.1
  • PCoIP Management Console 3.0.0
  • PCoIP Management Console 3.0.1