How do I recover from Recovery Mode?

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Problem

The PCoIP Zero Client OSD has a blue background with Recovery Mode with the message:

Warning: Recovery mode
This Zero Client is in Recovery mode due to a failure to boot, failed firmware upload or invalid configuration. Please alert your administrator to reset, verify settings, or upload firmware.

The web interface of the PCoIP Zero Client shows recovery mode with limited functionality.

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Cause

Starting in Firmware 5.0, recovery mode was introduced in the PCoIP Zero Client firmware. Recovery mode can be triggered by:

  • Incomplete firmware upload
  • Multiple failed boot attempts
  • Invalid configuration

Recovery mode is lightweight version of the standard firmware that allows for basic recovery procedures to restore functionality to the PCoIP Zero Client.

 

Resolution

To recover from recovery mode take the following steps:

  1. If a firmware upgrade was just attempted, re-try the upgrade.
  2. Power Cycle the PCoIP Zero Client by removing the power supply and try booting again.
  3. Factory reset the PCoIP Zero Client via the reset tab on the OSD or via the AWI.
  4. Re-download the PCoIP Zero Client firmware or newest and upload the firmware via the AWI. If you are on a WAN connection, use a local PC if possible to upload the file.