Connecting a new PCoIP Zero Client to an existing PCoIP Remote Workstation Card.

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In general, newer firmware in PCoIP Remote Workstation Cards (host cards) are backward compatible with PCoIP Zero Clients using older firmware.
However, enhancements to firmware may produce unexpected behaviors.

Important changes are documented in each firmware Release Details knowledge base article and in the firmware Release Notes. Current information on your PCoIP product can be found on the HP Anyware support site.

Scenario

A new PCoIP Zero Client is used to connect to an existing PCoIP Remote Workstation Card. The session type is set to Direct to Host + SLP Discovery. The Remote Workstation Card IP address is not shown and a pop up appears stating No available hosts for connection. However, an existing PCoIP Zero Client that's configured with the same session type shows the PCoIP Remote Workstation Card IP addresses available for connection and connects.

Cause

The new PCoIP Zero Client was flashed with the latest firmware at the factory. Since firmware 4.5.0, Port 50001 has been retired causing SLP discovered devices to not show up on the client end. Please see Remote Workstation Card TCP Port 50001 Retirement  and  Firmware 4.x.x Release Notes.

For this scenario, the PCoIP Remote Workstation Card did not receive a firmware update and the existing PCoIP Zero Client was also running earlier firmware. Port 50001 which carried SLP communications was active in both firmware versions and thus the IP addresses were displayed.

Resolution

Upgrade the firmware in the PCoIP Remote Workstation Card to the matching firmware version of the PCoIP Zero Client.

Note: It is recommended to use the latest version of firmware for each product.

Workaround:

Change the session type on the zero client to Direct to Host, enter the IP address of the host card and connect. For help finding the IP address, refer to How do I find the IP address of my newly installed PCoIP Zero Client or PCoIP Remote Workstation card?