Cannot connect: Get an ERROR: Failed to communicate with Connection Manager

Rate this Article
Average: 2 (2 votes)

Problem

When connecting to a HP Anyware PCoIP Agent the client receives the "Error: Failed to communicate with Connection Manager."

rtal

 

Cause

This error generally means something prevented the PCoIP Client to reach to the PCoIP Agent. The logs of interest is usually the PCoIP Agent and PCoIP Client logs. 
 

Generally this error will occur in one of these stages. Reasons for the error include:

  1. One or more required ports are blocked; TCP 443, 60443, 4172 and UDP 4172.
  2. If you are using HP Anyware Manager, the connector is not able to connect to HP Anyware Manager server,  "Unable to connect to HP Anyware Manager server".
  3. The trusted storage on Agent become corrupted. "This version of trusted storage is not supported."
  4. Windows legal notice is enabled and Single Sign-On (SSO) is also enabled
  5. Other

 

Resolution

 

1. One or more required ports are blocked; TCP 443, 60443, 4172 and UDP 4172.

The following Ports are required for the HP Anyware. Make sure these ports are not blocked.

HP Anyware  PCoIP Agents Port Port Number Direction Description
HP Anyware all PCoIP Agent versions (Standard & Graphics) TCP 443 In Client Authentication
  TCP 4172 In PCoIP Session Establishment
  UDP 4172 In and Out PCoIP Session Data
  TCP 60443 In Connection Broker Communication
  TCP 443 Out Cloud Licensing

 

2. If you are using HP Anyware Manager, the connector is not able to connect to HP Anyware  Manger server

Make sure that any firewall rule is not blocking the IP Address of HP Anyware Manager.

 

3. This version of trusted storage is not supported

Review the PCoIP Agent logs on the host for entries similar to:
AGENT: Failed to start the Agent:  Failed to add FNE trial license source: [1,7E3,4,0[70000027,0,5002E]]  This version of trusted storage is not supported.

It means the local trusted storage has become corrupted.

  1. Delete the contents of C:\ProgramData\Teradici\PCoIPAgent\licensing\5 in Windows, or /var/lib/pcoip-agent/licensing/5 (requires root permissions) in Linux.
  2. Restart the appropriate agent service (PCoIP Graphics Agent or PCoIP Standard Agent on Windows, or pcoip-agent on Linux)
  3. If using HP Anyware Cloud Licensing (not using a local license server), re-register the host.​​​​​

 

4. Windows legal notice is enabled and Single Sign-On (SSO) is also enabled

The windows legal notice or logon banner is not supported with Single Sign-On (SSO) as SSO is unable to send the message to the end user to click ok. This will prevent login and cause this error. 

To disable PCoIP session Single Sign On use one of the following methods:

 

Registry

  1. In the Run line, enter "regedit" (without quotes) and click OK.

  2. Browse to the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Teradici\PCoIP\pcoip_admin_defaults
    
  3. Right-click on pcoip_admin_defaults and select New > DWORD (32-bit) Value.

  4. Name the value pciop.single_sign_on

  5. Right-click on the new value and select Modify.

  6. In the Value data field, enter 0. Click OK to save your changes.

  7. Reboot to have the changes take effect.

 

Group Policy

To disable the logon banner on Windows, from Group Policy Editor: Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options: empty Interactive logon: "Message text for users attempting to log on", and "Interactive logon: Message title for users attempting to log on", then run gpupdate from command line to apply.

To disable SSO, please refer to section "Modifying the PCoIP GPO Variables" in administrators' guide, and disable the variable "Configure PCoIP session SSO access control".
 

5. Other

If none of the above apply or have fixed your issue please open a ticket with HP Anyware Global Support Services.