Why do my PCoIP Zero Clients randomly disconnect after upgrading to firmware 3.5.x to Firmware 4.8.1?

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Scenario

PCoIP Zero Clients randomly disconnect (approximately every 15-20 minutes) from the PCoIP session. In PCoIP Zero Client log file you can find the following lines:

0d,00:02:15> LVL:2 RC: 0 GSOAP :SOAP 1.2 fault: SOAP-ENV:Sender [no subcode]
0d,00:02:15> LVL:2 RC: 0 GSOAP :"End of file or no input: 'Bad file number'" Detail: [no detail]
0d,00:02:15> LVL:2 RC: 0 MGMT_CMI :Failed to communicate with https://1APC:50000 *

0d,00:02:15> LVL:2 RC: 0 MGMT_CMI :Failed multiple attempts to contact SOAP server!

*In this case 1APC is a legacy entry for another management device.

Cause


On the DHCP server there is already an Option 43 set for another management device (in this case 1APC). When the PCoIP Zero Client requests an IP address the Option 43 information is also passed along to the PCoIP Zero Client. The PCoIP Zero Client will now try to contact the management device in Option 43. Since it does not have the correct Vendor Class defined it will fail thus filling the PCoIP Zero client log files with the above entries.

Resolution

Have your network administrator verify that Option 60 and Option 43 are set correctly for the PCoIP device. The Vendor Class  identifier for PCoIP devices is "PCoIP Endpoint".