Another device on the network has the same IP address as this device. Please contact your network administrator for assistance.

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Problem

PCoIP Zero Client OSD shows, "Another device on the network has the same IP address as this device.Please contact your network administrator for assistance."

The PCoIP Zero Client or PCoIP Remote Workstation Card logs show:

0d,00:43:06.390> The current IP address (192.168.50.107) is being used by another system

Cause

If the IP address of a PCoIP Zero Client or PCoIP Remote Workstation Card (host card) is the same as that of another networking device in the network, your PCoIP device has an IP address conflict. For example, this issue may be due to the static IP address of your PCoIP device being identical to the dynamic IP address of another networking device in your network.

Resolution

If you are using a static IP address

  • Change the static IP address on the PCoIP Zero Client or PCoIP Remote Workstation Card and reboot the device. The PCoIP Remote Workstation Card will require a reboot of the workstation.
  • Unplug the PCoIP Zero Client or PCoIP Remote Workstation Card and attempt to connect to the duplicate IP address via PCoIP and other common protocols (80/443 Web, RDP) to establish what the device is. Change the devices IP.

If you are using a dynamic IP address

  • Check the PCoIP Zero Client or PCoIP Remote Workstation Card did not fail to get a DHCP address and is using the Fallback IP. What is the fallback IP address used for?  This is common after a network outage where the DHCP server is restored after the network. Multiple PCoIP devices can be in fallback mode using the same IP. Disconnect and reconnect the network cable to requesting an IP via DHCP or reboot the device.
  • Disconnect and reconnect the network cable or power cycle the PCoIP device to start the DHCP request process.
  • Change the DHCP reservation to a new unused IP and power cycle the PCoIP device.